Rolls-Royce and Bentley Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
Hi
My windscreen wipers work only on normal and fast speed but not in intermittent.
If I place the knob on intermittent, the wipers move but then they stop and remain blocked.
Any suggestions?
Thanks
 

·
Registered
Joined
·
2,697 Posts
Check the service manuals online. They usually have a flow chart for wiper diagnostics.
Try: Bentley heritage site
 

·
Registered
Joined
·
247 Posts
Hi!
I'll bump this thread instead of starting a new one, as my car has the same problem.
I've gone through IETIS and also had a look on the Australian forum, but can't find a diagnostics flow chart for the wipers.
Can anyone point me in the right direction?

Thanks!

Es
 

·
Registered
Joined
·
2,189 Posts
There are 3 relays and a controle module as far as I remember.
Check 3 relays under bonnet, normally wiper 1/2/3, used for start-stop, permanent-intermittent
Clean all contact and eventually exchange relays

Otherwise probably wash wipers ecu that you have probably on your car.
Sometime they can be fixed by replacing old or broken components
 

·
Registered
Joined
·
247 Posts
Thanks Jean!
I did replace the relays in the engine compartment with standard Bosch-type ones, but that didn't do the trick.
I'll try to find the ecu and have a look at that next.

Cheers

Es
 

·
Registered
Joined
·
247 Posts
Hi!
I've just replaced the wash/wipe ECU with a 2nd habe one, but the intermittent setting still don't seem to work...
I'll have another look at the relays in the engine compartment, but I'm at a bit of a loss.
Could it be the switch?

Cheers

Es
 

·
Registered
Joined
·
247 Posts
Hi!
I replaced all the relays with standard Bosch-type ones, to eliminate those as a cause.
I can get about half a cycle on the lowest intermittent setting, but the rest are still "dead".
I think I'll have to get the voltmeter out...

Cheers

Es
 
1 - 11 of 11 Posts
Top