Rolls-Royce and Bentley Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My 1990 Turbo R, 107K miles, refused to start last May after six weeks of inactivity. It turned over fine, but there was no spark until the starter disengaged, at which time it occasionally caught and ran normally.

I towed it to my dealer, who wasted three weeks trying to diagnose the problem, after which I demanded that he tow it back. The dealer wanted to replace the ECU and spark amplifiers for a total cost in excess of US$5,000. Then I had the ECU checked out by two competent shops (UK and Florida) who found no faults.

Then I dug into the service manual and discovered that a bad engine-chassis ground could be the source of the problem. It was! Adding a US$5 ground strap solved everything. Hope this helps someone.

George Bullwinkel (Illinois)
 

·
Registered
Joined
·
6 Posts
hello,

i have a 1991 Turbo R and it won´t crank !

whe i turn key in RUN position the DIP doesn´t light up at all
only when i turn on park-lights some very low lights ignite.

also it doesn´t crank when i turn the key to start the engine.

it seems that the main circuit doesn´t have any power at all.

where did you fit the ground strap ?

can i connect a jump lead to the engine and body to try if this maybe the fault ?

thanks a lot !
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
My suggestions for your hard-starting Bentley:
1. Be sure your battery is fully charged.
2. Check that the battery cut-off switch is engaging properly.
3. Connect a grounding jumper cable between the engine (I used a cam cover nut) and frame (I used a front shock mount).
Then try it again. My guess is that the cut-off switch and/or ground cable (under the engine, right rear corner) are defective. Good luck! George
 

·
Registered
Joined
·
11 Posts
mayday mayday, engine crank no start

Hello everyone,

Good to touch base. It's always a delight to read how you fix up the problems. This time I have problem starting my Turbo R which has been inactive for three long month. More importantly I have recently changed the battery. I would be grateful to anyone giving any suggestion that could help me start the car that I must send to the garage for a complete overhaul.

cheers
 

·
Registered
Joined
·
1,265 Posts
Hi George ,I'm sure I told someone on here to check the engine ground, maybe you missed it. It's a common failure.
Frank give us a clue, cranking? Not firing?
Mike
 
1 - 5 of 5 Posts
Top