Rolls-Royce and Bentley Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, we have a Silver Seraph 00 with us. Temporary settings of the speedometer off and the relays click every second. The low beam also flickers. The speedometer does not pulse, it is dark all the time and also ticks. Then I can remove fuse 13 (10A) from the fuse and relay box in the driver's footwell and everything is quiet. Has anyone had concerns issues? How would you proceed? Many thanks for the help
29561
29562
29563
 

·
Registered
Joined
·
63 Posts
Hi Stan, Can't help you on the issue. If you're located more or less close to Zurich I can offer you to take a look at a functional 05 Arnage, if this is helpful. Cheers, GD
 

·
Registered
Joined
·
63 Posts
PS: Remote support from independent specialized mechanics in UK like Bowling-Ryan Bentley & Rolls Royce Service (the owner is a very very nice and competent gentleman!) has been very helpful to me. I'd probably start there if I were you.
 

·
Registered
Joined
·
637 Posts
Headlights randomly flickering, or flickering in time with the relay clicking? My next port of call would be to figure out which relay is clicking either way....
 

·
Registered
Joined
·
2,208 Posts
low beam/ headlights issue on late Bentley is usually the ECU

But it does not impact as far as I know anything else, but with electronic/electricity many things are possible

Check indeed if you have this ECU under the bonnet, left side under plastic close to the suspension spring area.
 
1 - 8 of 8 Posts
Top