Rolls-Royce and Bentley Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all,

I'm looking for suggestions, 1998 Silver Seraph, reverse is not selecting properly. The other gears select as they should but reverse will not immediately engage. After a few moments of 'knocking' the lever it will get reverse but obviously this is not right so I'd like to know if anyone else has had this problem and if so what the remedy was before money is spent!

Thanks in advance,

Tom
 

·
Registered
Joined
·
2 Posts
I did a service call a couple of years ago on one of these with a similar problem. I found the single screw which holds the lever onto the selector had come loose. Take off the plastic surround and check that first.
I have the same problem. What was your final solution? Was it the loose lever screw?
 

·
Registered
Joined
·
68 Posts
Have you checked the range switch on the side of the transmission? This feeds info to the TCU. It has tiny microswitches which can fail. If the P- R-N-D-4-L signals are illuminating on your DIP then this switch is OK. If not, it is a problem. For some reason this switch gets its power from the same fuse that powers the E-box cooling fan. This fan can seize and blow the fuse. The other possibility is that the linkage from the shift actuator to the transmission is slightly out of adjustment. With the shift lever in Park remove the pin from the clevis on the transmission and see if the clevis lines up exactly with the shift arm when it is all the way forward in the Park position.
 
1 - 5 of 5 Posts
Top