Rolls-Royce and Bentley Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Does anyone know if it is possible to manually adjust the driver seat? (2007 Arnage T) Mine is "parked" way up to the steering wheel leaving the car undrivable.

I had issues adjusting the seat (possible to adjust one in about fifty times when turning the ignition ON/OFF).

I changed the module PW55147PBSXR controlling the seat/mirrors/steering but still.. the same problem.
On the left side it works fine (also the reset routine works on this side).

Now, I have ordered a seat control panel switch (hoping that this might be the problem) and in the meantime I`d love to use the car..
 

·
Registered
Arnage T MY 05
Joined
·
201 Posts
I have no specific knowledge of this kind of problem in the Arnage, but in a Range Rover Classic I had a similar problem linked to the switch.

The switch had poor contact and disassembly + cleaning temporarily did the trick for me. New switch was necessary however.
 

·
Registered
Joined
·
8 Posts
Bonjour, avez-vous pensé à initialiser le module ?
MODULE CTRL F/SEAT DRVS RECON EXCHANGE (VERSER INITIALISER PRESS MEMORY 5 X & ENTER 2332) (PW55147PBSXR)

Moderator wrote: Please translate yourself and post in English. This is an English based forum and if you expect to get or offer helpful advice you should post in the language used.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #5 ·
I see that there are several with similar issues on the older Bentleys Turbo R...

Well, I got desperate, I managed to locate the power cords from the motors under the seat and just hit the pins that goes into the module with 12V. In this way, I was able to adjust the seat. Now I am one step closer to thinking that the problem is in fact the switch. At least I can take the car out while waiting for the control panel. :)[/QUOTE]
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #7 ·
Yes, fuses are okay :) Got the new (old) switch panel today from flying spares - 350usd + shipping and Norwegian VAT 25%. This thing is massive and it looks like a NASA computer component from the 70ies. The memory (left) buttons have that clicking noise and feel as compared to my old one. This I'm hoping could be due to some spillage causing the malfunction (steering wheel/driver seat/mirrors) and stopping this loop from working. I`ll keep you updated once this is in. Looks like this is mounted from the underside? I guess it's not done in 5 minutes.

Finger Carnivore Gas Gadget Dog breed
Circuit component Wood Finger Material property Engineering
Circuit component Green Electronic component Electronic engineering Hardware programmer
 

·
Registered
Joined
·
214 Posts
Good luck. The switch panel controls individual functions so if no function is working the cause is most likely no power supply to the panel or no power supply to the control module. You need to remove the storage box to access the switch panel mounting screws.
 

·
Registered
Joined
·
214 Posts
Following up on this, do your mirror and steering adjustment functions work? These have nothing to do with the seat switches but are controlled by the seat module. If they work then the module is probably OK. If not, you have a bad module or no power to module. The seat switches get their power from the seat module.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #10 ·
Thanks for replying! Yes, I changed the module already, but still no luck (look in my first post)

This is the weird part:
If I delete memory faults (no faults other than airbag), then everything works for some seconds - then dead.
I shut the power down, and once power is on only forward movement is possible. No mirrors or steering adjustments is possible.
This means that there is power to the module?

Once the seat is all the way up, you can still feel and hear the motor nr 2 (forward/backward) clicking for microsecond when pressing forward on the seat switch, or even the memory buttons.

I`m hoping that the old switch panel is full of some old milkshake or whatever, causing all this. We`ll see!

Mine is a 2007 and there is no storage box behind the panel like the pre-facelifted ones, or are you thinking of the little space below the moving armrests?
The main panel between the seats seems to pop off but around the gear level, I`m kind of stuck for my home DIY approach...
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #11 ·
Installed new switch panel (was easy) and a new module and reset program. Still same problem: no left seat/steering wheel/mirrors working. Left seat will move forward ONLY with the door open (!). Does anybody have diagrams of the wiring? Could this be from a bad grounding?
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #12 ·
I`m turning desperate to solve my driver seat/mirroors/steering column INOP status.

The only way I can regulate the seat is by feeding 12v directly into the motors. Not ideal, and the look of me operating the seat this way, with my butler holding the Bentley umbrella in one hand and the original whiskey glass in the other hand and me down on my knees with my face in under the seat looks disrespectful for the Bentley Arnage.

Who on this planet can help me? I`ll ship the car to the garage that can fix this..
 

·
Registered
Joined
·
2,559 Posts
Don't know if Bowling Ryan is related to Bowling engineering which is for me the best specialist.
You should start there in any case, best chance to solve your issue

This kind of company is a treasure for RR/Bentley owners.

[email protected]

Bowling Engineering Ltd,
Unit 5 Fishbrook Ind Est,
Stoneclough Road,
Kearsley,
Bolton BL4 8NF
Tel + 44 1204 862500.
 

·
Registered
Joined
·
3 Posts
Hello, did u win with your Bentley issue? I've got this same with mine Arnage T, 2007year - i have no idea what's going wrong. I know how to bypass the problem but not how to repair IT without extra wire on PCB board.
 

·
Registered
Joined
·
3 Posts
Additionaly conclusions:

If you give an extra +12 from ignition to 10pin (by service wiring diagram: "Key in switch signal", white small 12pin connector from behind of module, close to the second one white bigger connector") adjustment work fine but i think it's not a true cause of issue. It isn't perfectly solution because it's only cheating the control module. I checked everything but wiring diagramsare innacurate as duck.
 

·
Registered
Arnage T MY 05
Joined
·
201 Posts
Have you tried this:

 
1 - 18 of 18 Posts
Top