Rolls-Royce and Bentley Forums banner

1 - 20 of 34 Posts

·
Registered
Joined
·
3,448 Posts
Discussion Starter #1
Suddenly, as in sometime during the last couple of days, I am having major problems any time I try to either reply to an existing thread or post a new message. I am running Windows 10 Home, 64-bit, and using Firefox 46.0. I have been using Windows 10 since last fall and Firefox in its various releases over that time too.

The two attached error messages, both from scripts, are what came up when I tried to reply to a message a few minutes ago and when I tried to start creating this message, respectively.

Very often these are followed by Firefox going into "Not Responding" mode for a period of time.
 

Attachments

·
Administrator
Joined
·
153 Posts
Hey there,

Thank you for bringing this to our attention.
This issue may be caused by some add-ons/plugins you may have installed in your browser.
If you do have any plugins/add-ons installed, can you try running your browser in "Safe Mode" and make sure that you select "Disable all add-ons".
If the problem does not continue, then it must be one of the add-ons.
From there, it may be a pain, but your best bet would be to turn them on one-by-one until the error pops up again.

If not, it could also be some of Chrome's add-ons that are causing these issues.
It seems as of late this is a known issue, so if you have add-ons in chrome, disable them, clear your cache and cookies in both browsers, and see if that helps.

Let us know if any of this helped.

Thank you,

Richard.
 

·
Registered
Joined
·
3,448 Posts
Discussion Starter #3
Richard,

Thanks for the suggestions, and I can do these, but I hasten to add that this issue is not occurring in Chrome, but in Firefox, and, yes, that script that has chrome in its name does run under Firefox. I've seen scripts with chrome in their names run under other websites when using Firefox, too, so they're clearly not Chrome specific.

I've actually jumped over to Chrome for this particular forum since posting last night just to see if/when the problem would recur in another browser and, so far, it has not done so.
 

·
Registered
Joined
·
585 Posts
I believe it may be specific to this forum -- I was also experiencing it using Firefox on Mac, but it went away when I started using Safari for just this forum.

(I found I liked Safari enough after a couple of weeks to switch entirely, so I can't be 100% sure the problem was specific to this forum.)

Cheers,
Jeff.
 

·
Administrator
Joined
·
153 Posts
Hi,

Do you happen to have any browser addons like ad blockers and such?

I'm using Firefox on a Mac as well with no addons and have yet to see a script error.

~Sheena
 

·
Registered
Joined
·
3,448 Posts
Discussion Starter #7
I'll note that I do have Adblock Plus, HTTPS Everywhere, and Ghostery installed but none have been updated around the time this issue triggered.

I also have these add-ons in Chrome and am not having the issue.

This post is coming from Firefox running in safe mode, and I did not get a script error this time. I will restart in normal mode and see if the errors return.
 

·
Registered
Joined
·
3,448 Posts
Discussion Starter #8
For the moment, the problem has disappeared. I do, however, expect it to return given the pattern lately. If it shows up again under Firefox I'll try to snag screen shots and report back.
 

·
Administrator
Joined
·
153 Posts
I appreciate it. Having screenshots helps our tech team pin down issues much quicker than explaining issues sometimes.

Even if your plugins have not been updated, that could be conflicting with maybe one of the site's latest plugin updates. A lot of the functions on here are plugins, and when the developer updates them, sometimes we notice small conflicts.

~Sheena
 

·
Registered
Joined
·
3,448 Posts
Discussion Starter #10
Just tried replying to the Coachbuilt 71 thread, using the "Quote" button, and it threw Firefox into a "(Not Responding)" state for about 35-40 seconds followed by a script error. Screen shot of error dialog attached.
 

Attachments

·
Registered
Joined
·
3,448 Posts
Discussion Starter #12
Sheena,

I am almost certain that in all instances I was quoting, but I cannot be 100% certain.

If something comes up for a no-quote reply I'll add to the thread. This reply, sans quotation, worked just fine.
 

·
Administrator
Joined
·
153 Posts
Sheena,

I am almost certain that in all instances I was quoting, but I cannot be 100% certain.

If something comes up for a no-quote reply I'll add to the thread. This reply, sans quotation, worked just fine.
Test.

Still haven't been able to recreate this. Can you link the thread where you got the error?

Kevin
 

·
Registered
Joined
·
3,448 Posts
Discussion Starter #14
Test.

Still haven't been able to recreate this. Can you link the thread where you got the error?

Kevin
How about this one. You can see your quotation as it showed on my screen, complete with the script error box.

I realize that this is frustrating and that you can do nothing until or unless you are able to recreate the issue. Later this evening I'll try seeing if I get the same error in Firefox safe mode if I try to quote. If I don't I'll turn off my add-ons one at a time to see if I can isolate something.

Brian
 

Attachments

·
Registered
Joined
·
3,448 Posts
Discussion Starter #15 (Edited)
Just got the below when doing another quoted reply on the 1971 Coachbuilt thread. I am not getting the error now, replying to this thread sans quotation.
 

Attachments

·
Administrator
Joined
·
153 Posts
Still haven't been able to recreate the error, but at this point it's time to send along to tech anyways. This will be Case #1957221

Kevin
 

·
Administrator
Joined
·
153 Posts
Tech got back to me. They want you to select the "Debug Script" option next time it shows up and copy the information that it says when you do.

Kevin
 

·
Registered
Joined
·
3,448 Posts
Discussion Starter #18
Kevin,

The best I can do is this:

/*======================================================================*\
|| #################################################################### ||
|| # vBulletin 3.8.8
|| # ---------------------------------------------------------------- # ||
|| # Copyright ©2000-2014 vBulletin Solutions, Inc. All Rights Reserved. ||
|| # This file may not be redistributed in whole or significant part. # ||
|| # ---------------- VBULLETIN IS NOT FREE SOFTWARE ---------------- # ||
|| # http://www.vbulletin.com | http://www.vbulletin.com/license.html # ||
|| #################################################################### ||
\*======================================================================*/
function vB_Attachment(A,B){this.attachments=new Array();this.menu_contents=new Array();this.windows=new Array();this.listobjid=A;if(B==""){for(B in vB_Editor){if(YAHOO.lang.hasOwnProperty(vB_Editor,B)){this.editorid=B;break}}}else{this.editorid=(B?B:null)}}vB_Attachment.prototype.popup_exists=function(){if(this.editorid&&((typeof vB_Editor[this.editorid].popups.attach!="undefined"&&vB_Editor[this.editorid].popups.attach!=null)||(!vB_Editor[this.editorid].popupmode&&typeof vB_Editor[this.editorid].buttons.attach!="undefined"&&vB_Editor[this.editorid].buttons.attach!=null))){return true}else{return false}};vB_Attachment.prototype.add=function(D,B,C,A){this.attachments[D]=new Array();this.attachments[D]={filename:B,filesize:C,imgpath:A};this.update_list()};vB_Attachment.prototype.remove=function(A){if(typeof this.attachments[A]!="undefined"){this.attachments[A]=null;this.update_list()}};vB_Attachment.prototype.has_attachments=function(){for(var A in this.attachments){if(YAHOO.lang.hasOwnProperty(this.attachments,A)&&this.attachments[A]!=null){return true}}return false};vB_Attachment.prototype.reset=function(){this.attachments=new Array();this.update_list()};vB_Attachment.prototype.build_list=function(A){var B=fetch_object(A);if(A!=null){while(B.hasChildNodes()){B.removeChild(B.firstChild)}for(var D in this.attachments){if(!YAHOO.lang.hasOwnProperty(this.attachments,D)){continue}var C=document.createElement("div");if(typeof newpost_attachmentbit!="undefined"){C.innerHTML=construct_phrase(newpost_attachmentbit,this.attachments[D]["imgpath"],SESSIONURL,D,Math.ceil((new Date().getTime())/1000),this.attachments[D]["filename"],this.attachments[D]["filesize"])}else{C.innerHTML='<div style="margin:2px"><img src="'+this.attachments[D]["imgpath"]+'" alt="" class="inlineimg" /> <a href="attachment.php?'+SESSIONURL+"attachmentid="+D+"&stc=1&d="+Math.ceil((new Date().getTime())/1000)+'" target="_blank" />'+this.attachments[D]["filename"]+"</a> ("+this.attachments[D]["filesize"]+")</div>"}B.appendChild(C)}}};vB_Attachment.prototype.update_list=function(){this.build_list(this.listobjid);if(this.popup_exists()){vB_Editor[this.editorid].build_attachments_popup(vB_Editor[this.editorid].popupmode?vB_Editor[this.editorid].popups.attach:vB_Editor[this.editorid].buttons.attach,vB_Editor[this.editorid].buttons.attach)}};vB_Attachment.prototype.open_window=function(B,C,A,D){if(typeof (this.windows[D])!="undefined"&&this.windows[D].closed==false){this.windows[D].focus()}else{this.windows[D]=openWindow(B,C,A,"Attach"+D)}return this.windows[D]};

----------------------------------------------------------------------
I don' think that the above is complete, but I can see no obvious way to do a "full dump" to a file and this is a copy & paste of what I had easy access to when I tried a reply with quote to this post. Things also froze up once the Debugger was up and I had to close the tab entirely and open a new tab in order to post what's here without quotation.
 

·
Registered
Joined
·
3,448 Posts
Discussion Starter #20
Just so you know, this issue has never ceased. I just had a new post about another issue hit the script issue, and then Firefox crashed. I'm doing this one from under Chrome and will be doing the other one I'd been working on under Chrome as well.
 
1 - 20 of 34 Posts
Top