Rolls-Royce and Bentley Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hi gentlemen! My Mulsanne Turbo ´84 has a defect fuelpump and I wonder if anyone know if I can use a high capacity pump from Bosch, a 044 type?
Or do You have another suggestion other than buying a new one from for example Introcar or Flying Spare?!

The 044 pump has a M18 and a M12 connection (and M6 and M7 for the wiring)!
Do anyone know what connections the orignalpart has? It´s still on the car so I can´t tell myself!

Maybe I´m lucky and one of You have one to spare?


Steve
 

·
Registered
Joined
·
3 Posts
Maybe the pump from a 1994 dodge viper would work?

A new one is around $100 on ebay and if the fittings do not match up you could simply adapt the fittings to match the tread.

I still have the old pump when I replaced mine and from what I can tell it is very close to the one you have on your car, could you post a picture?

This is just in the interest of saving a few dineros, but if you dont't mind spending a few extra just go with the direct fit to save yourself the headache.

ebay is a good source to find cheap auto parts.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
After some own research, I now know that the pump that Bosch manufactures today has following SN-OES (as they call it) 058 025 4938!!
 

·
Registered
Joined
·
9 Posts
Hi gentlemen! My Mulsanne Turbo ´84 has a defect fuelpump and I wonder if anyone know if I can use a high capacity pump from Bosch, a 044 type?
Or do You have another suggestion other than buying a new one from for example Introcar or Flying Spare?!

The 044 pump has a M18 and a M12 connection (and M6 and M7 for the wiring)!
Do anyone know what connections the orignalpart has? It´s still on the car so I can´t tell myself!

Maybe I´m lucky and one of You have one to spare?


Steve
Hi steve
What are the symptoms regards to the defective fuel pump?
My 83 mulsanne turbo is problematic
Best regards Stephen mullan
 

·
Registered
Joined
·
1,303 Posts
On my 83 mulsanne turbo it was the fuel pump ballast resistor that was the problem not the pump. Might be worth checking ok.
 
1 - 5 of 5 Posts
Top