Rolls-Royce and Bentley Forums banner
1 - 6 of 6 Posts

·
Registered
1970 Silver Shadow RHD, 2013 Nissan Leaf, 1986 Toyota RV, 2000 Nissan Frontier, 2006 Honda ST 1300,
Joined
·
26 Posts
Discussion Starter · #1 ·
I took apart both brake switches and cleaned them really well inside. Still they don't work. Any suggestions please? 1970 Silver Shadow right hand drive. Neither light up. The bulbs work.
Grey Gas Art Metal Concrete
 

·
Super Moderator
Joined
·
1,079 Posts
Did you ensure the plastic plunger moves freely in the metal disc? They are usually swollen and stuck. Did you put a new rubber disc in? Clean the end of the spring where it contacts the disc and brass terminal connection?
 

·
Registered
1970 Silver Shadow RHD, 2013 Nissan Leaf, 1986 Toyota RV, 2000 Nissan Frontier, 2006 Honda ST 1300,
Joined
·
26 Posts
Discussion Starter · #5 ·
I don't remember a rubber disk. I remember a spring, a diaphragm, a metal plate like object that fits into the spring. I'll take it apart and take some pictures.
 

·
Registered
1970 Silver Shadow RHD, 2013 Nissan Leaf, 1986 Toyota RV, 2000 Nissan Frontier, 2006 Honda ST 1300,
Joined
·
26 Posts
Discussion Starter · #6 ·
Did you ensure the plastic plunger moves freely in the metal disc? They are usually swollen and stuck. Did you put a new rubber disc in? Clean the end of the spring where it contacts the disc and brass terminal connection?
The plastic plunger does not move freely. I have ordered two new plastic plungers to begin with. The rubber disk looks good. I'll replace that next. I will clean the spring. Thank you.
 
1 - 6 of 6 Posts
Top