Rolls-Royce and Bentley Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Recently purchased my first Rolls Royce problem with front lights not working but rear and indicators all okay lights were working but tried today no go checked fuses all good anyone advice etc
 

·
Registered
Joined
·
1,992 Posts
Welcome to the forum. Sometimes the glass fuses can be good but the contacts may be corroded. It's sometimes not obvious that the fuse wire is broken if the break is behind the metal contact at the ends of the fuse. I suggest a continuity test of the fuse or swap fuse and clean fuse board contacts.
 

·
Registered
Joined
·
26 Posts
Hi
I have no idea of it is the same but I had similar symptoms on my Corniche about 2 years ago not long after I bought it.
Fuses and relays for the headlights all OK - ( I was amazed how many relays the things has - and dotted all over not just in the main fuse box!.)
But there is also another relay for switching main to dip beam - its much larger than the usual relays, with 5 cables if I rember correctly - mine is under the bonnet, fairly close to the suspension on the left hand side.
It was expensive too - something like 130 euros, but solved the issue.
cheers
Chris
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Hi Gents checked fuses all okay has to be relay does anyone have any auto electricians in Ireland around north/west.No cowboys if anyone has any numbers let me know only need this problem rectified and I'll be in tip to shape for summer.
 

·
Registered
Joined
·
2,316 Posts
Where are the fuses you checked located under the bonnet or in the car ?
Do you have fuses under the bonnet on the left side ? A little black box ?

WHich kind of fuses you have ?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Where are the fuses you checked located under the bonnet or in the car ?
Do you have fuses under the bonnet on the left side ? A little black box ?

WHich kind of fuses you have ?
The fuses located under glove box they are the old type glass fuses checked all lights were working only headlights not all other lights indicators/brake/reg/indicators etc all okay okay mechanical side but electrics bit weary can change a fuse and bulbs etc but not much more it's a1985 silver spur
 

·
Registered
Joined
·
2,316 Posts
OK, so only headlights with blue indicator on the dash are not working ?
Please confirm that when you put the light switch in second position you have indeed some lights ON but only head lights for long distance not working.
Just to make sure what is your issue

I suppose you know how to put them ON and OFF
I am asking because some people do not know and believe thet are not working.
 

·
Registered
Joined
·
671 Posts
I'd be happy to take a look at it, but I'm a bit of a hike from you (I'm in Co Louth). I'm not an auto elecy; just a DIY whose been around the block a few times....
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
That would be great I would quite happy to pay you no issues there for your time and fuel if your interested regards Lee
 

·
Registered
Joined
·
671 Posts
Sorry I might have misled you: I'd be happy to take a look at it if you bring it by my place. ;)

(But no payment required. I enjoy tinkering with cars.)

Cheers,
Jeff

PS: direct email is [email protected] if you want to contact me.
 
1 - 13 of 13 Posts
Top