Still dead! 1991 Silver Spur II - Rolls-Royce and Bentley Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 07-11-2019, 07:29 PM Thread Starter
Member
 
Join Date: Jan 2019
Location: Bangor, Maine
Posts: 22
Still dead! 1991 Silver Spur II

The continuing saga of our Silver Spur.

We finally found the fusible link and replaced it. It shorted out from contact with the alternator. With a new one spliced in, we expected everything would go back to normal, but that didn't happen. All the lights and accessories came back to life, but the starter circuit is still totally dead. The shifter is in park, and in neutral it still has no sign of life. Battery is fully charged. When the key is turned on, we don't hear the fuel pumps or any relays clicking.

I'm looking for some suggestions on where to look next? Any ideas?
Bettsbooks is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 07-12-2019, 04:42 AM
Senior Member
 
Join Date: Jun 2016
Location: FR
Posts: 1,747
Would it be possible that an animal such a mouse or bigger has eaten cables ?
That is a classical issue and now they offer products against those animlas, necessary when you are in the country as even a small mouse could destro electric cables and the cas will not start if the loom is dammaged somewhere.

Last edited by Jean7; 07-12-2019 at 04:47 AM.
Jean7 is offline  
post #3 of 25 (permalink) Old 07-12-2019, 04:53 AM
Senior Member
 
mikebentleyturbo2's Avatar
 
Join Date: Jun 2015
Location: Cannock ,staffs ,uk
Posts: 1,128
Garage
Hi Jean yes mine have been nibbled but they liked the foam insulation better lol
Bettsbooks
First check f1 b4 is it live?and intact?
Does ign relay 1 (under glove box) click when ign switch is turned on?
Let me know OK
Mike

chassis 27650
mikebentleyturbo2 is offline  
 
post #4 of 25 (permalink) Old 07-12-2019, 01:28 PM
Senior Member
 
Jim Walters's Avatar
 
Join Date: Mar 2014
Location: Cobble Hill, BC, Canada
Posts: 422
Send a message via AIM to Jim Walters
On a Spur II there are two start related relays under the plastic cover immediately behind the right front shock tower. Pull them off and on a couple times to see if that works. Hidden where they are they tend to get corroded terminals and are rarely checked. If the terminals are badly corroded you should use some contact cleaner on the socket and replace the relays.

SRH8505 SRC18015 SRE22493 NAC-05370
www.bristolmotors.com
Jim Walters is offline  
post #5 of 25 (permalink) Old 07-18-2019, 06:42 PM Thread Starter
Member
 
Join Date: Jan 2019
Location: Bangor, Maine
Posts: 22
Mike, no noise from the relays. And thankfully no signs of little furry critters chewing on anything!
Bettsbooks is offline  
post #6 of 25 (permalink) Old 07-18-2019, 06:43 PM Thread Starter
Member
 
Join Date: Jan 2019
Location: Bangor, Maine
Posts: 22
Jim, we've checked those relays and have actually swapped them, but it hasn't made any difference.
Bettsbooks is offline  
post #7 of 25 (permalink) Old 07-18-2019, 09:54 PM
Senior Member
 
Jim Walters's Avatar
 
Join Date: Mar 2014
Location: Cobble Hill, BC, Canada
Posts: 422
Send a message via AIM to Jim Walters
The other ignition relay that runs the fuel pump is under the fuse blocks. Replace it then you can start it by using a jumper on the under hood relay. Have you checked the plastic coupler in the ignition switch? Common for them to break.

SRH8505 SRC18015 SRE22493 NAC-05370
www.bristolmotors.com
Jim Walters is offline  
post #8 of 25 (permalink) Old 07-19-2019, 06:41 AM Thread Starter
Member
 
Join Date: Jan 2019
Location: Bangor, Maine
Posts: 22
Jim, the ignition switch is our next thing to check. Thanks.
Bettsbooks is offline  
post #9 of 25 (permalink) Old 07-19-2019, 07:37 AM
Senior Member
 
mikebentleyturbo2's Avatar
 
Join Date: Jun 2015
Location: Cannock ,staffs ,uk
Posts: 1,128
Garage
Hi
Is this car cranking and not staring or not cranking?
Mike

chassis 27650
mikebentleyturbo2 is offline  
post #10 of 25 (permalink) Old 07-19-2019, 09:34 PM Thread Starter
Member
 
Join Date: Jan 2019
Location: Bangor, Maine
Posts: 22
Not cranking at all.
Bettsbooks is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Rolls-Royce and Bentley Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

SEO by vBSEO 3.6.1