AC/Heater Blower Fans - Rolls-Royce and Bentley Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-18-2019, 05:11 PM Thread Starter
Member
 
Join Date: Aug 2016
Posts: 45
AC/Heater Blower Fans

I drove my 79 Shadow II today. Suddenly, the blower fans for the AC/heat stopped working. I turned the switch off and back on, and they would start blowing again for less than a minute to 5 or more minutes each time. After going through this off/on, they worked continuously for the rest of the trip (about 30 minutes). Long story short, when they stop working, they immediately come back on when moving the switch to off & back on, but would not stay on. Any idea what is going on? The AC air was very comfortable on a 98F day with no overheating!

Thanks!

Richard
xke190sl is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Rolls-Royce and Bentley Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

SEO by vBSEO 3.6.1